Please either Logon or create a New Account.
Tag
PS11 upgrade (1)
Just upgraded from 10.1x to 11.0.1, had also attemped an upgrade to 11.0.0.1.  All cases produced the following problem:

Upgrade install proceeds normally and successfully.  Starting PS service results in the PowerSchool Message service quitting and the following message in the PS Monitor:  ERROR PSLog - Unable to connect to the Application Message Service at tcp://x.x.x.x:61616. PowerSchool will continue to attempt the connection for the next 5 minute(s).

The next schema update seems to complete, but a restart of the services brings you right back to the same place, with the same schema update.

Found a solution on PowerSource at https://support.powerschool.com/article/75808

The article states that the kahadb database isn't getting verified, with kills the message service.  The solution is to rename the kahadb folder and start services, which generates a new kahadb.  There is a warning that other connected subscription services such as EdFi may not receive messages from PS, and that a full sync may be required.

I haven't checked on EdFi yet, but this did solve my problem.  Just wanted to share in case anyone else runs into this when upgrading to PS 11.0.x.  Not sure if this affects hosted users.

Dave
Comments
1 Response to "PS 11 upgrade issue with message service error on attempted startup."

Dave,
I had the same issue it was the  Kahabd folder I called support and they renamed the kahadb folder.  Here is the ticket info Suzanne and I were able to resolve the issue by shutting down all PowerSchool services, renaming the kahadb folder, and starting the services. We verified that no errors were in the logs and the startup was successful.

It also worked for me.

Suzanne

Post Your Comment



  1